#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-z]{3,6}) (\/.*) HTTP\/(\d\.\d)"
Local $sString = "GET /img/low-poly-ice-caps.jpg HTTP/1.1" & @CRLF & _
"Content-Type: text/html; charset=utf-8" & @CRLF & _
"Server: hhttpp\n" & @CRLF & _
"" & @CRLF & _
" <!DOCTYPE HTML>" & @CRLF & _
" <html>" & @CRLF & _
" <body>" & @CRLF & _
" <h1>Hello, World!</h1>" & @CRLF & _
" </body>" & @CRLF & _
" </html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")