re = /([A-z]{3,6}) (\/.*) HTTP\/(\d\.\d)/m
str = 'GET /img/low-poly-ice-caps.jpg HTTP/1.1
Content-Type: text/html; charset=utf-8
Server: hhttpp\\n
<!DOCTYPE HTML>
<html>
<body>
<h1>Hello, World!</h1>
</body>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end