import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-z]{3,6}) (\\/.*) HTTP\\/(\\d\\.\\d)";
final String string = "GET /img/low-poly-ice-caps.jpg HTTP/1.1\n"
+ "Content-Type: text/html; charset=utf-8\n"
+ "Server: hhttpp\\n\n\n"
+ " <!DOCTYPE HTML>\n"
+ " <html>\n"
+ " <body>\n"
+ " <h1>Hello, World!</h1>\n"
+ " </body>\n"
+ " </html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}