const regex = /(?P<Timestamp>\b(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)\b[\s+\w+]+[\w+:?]+)\s+(?<SourceIP>[\d+\.?]+)\s+(?P<EventID>%PIX-6-\d+):\s+(?P<EventMessage>Teardown TCP connection\s+\d+) for (?P<OutsideIP>.*?) to (?P<InternalIP>.*?)\s+duration\s+(?P<Duration>.*?)\s+bytes(?P<Bytes>\s+\d+)\s+(?P<TCPstatus>.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<Timestamp>\\b(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)\\b[\\s+\\w+]+[\\w+:?]+)\\s+(?<SourceIP>[\\d+\\.?]+)\\s+(?P<EventID>%PIX-6-\\d+):\\s+(?P<EventMessage>Teardown TCP connection\\s+\\d+) for (?P<OutsideIP>.*?) to (?P<InternalIP>.*?)\\s+duration\\s+(?P<Duration>.*?)\\s+bytes(?P<Bytes>\\s+\\d+)\\s+(?P<TCPstatus>.*)', 'g')
const str = `Jul 25 23:56:20 210.56.128.109 %PIX-6-302014: Teardown TCP connection 71946380 for Outside:203.117.152.202/80 to Corp-DMZ:proxy2/14266 duration 0:00:00 bytes 557 TCP FINs
Jul 25 23:56:20 210.56.128.109 %PIX-6-302014: Teardown TCP connection 71946381 for Corp-DMZ:proxy2/8080 to Internal:172.20.8.18/65181 duration 0:00:00 bytes 602 TCP FINs`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}