// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?P<Timestamp>\b(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)\b[\s+\w+]+[\w+:?]+)\s+(?<SourceIP>[\d+\.?]+)\s+(?P<EventID>%PIX-6-\d+):\s+(?P<EventMessage>Teardown TCP connection\s+\d+) for (?P<OutsideIP>.*?) to (?P<InternalIP>.*?)\s+duration\s+(?P<Duration>.*?)\s+bytes(?P<Bytes>\s+\d+)\s+(?P<TCPstatus>.*)").unwrap();
let string = "Jul 25 23:56:20 210.56.128.109 %PIX-6-302014: Teardown TCP connection 71946380 for Outside:203.117.152.202/80 to Corp-DMZ:proxy2/14266 duration 0:00:00 bytes 557 TCP FINs
Jul 25 23:56:20 210.56.128.109 %PIX-6-302014: Teardown TCP connection 71946381 for Corp-DMZ:proxy2/8080 to Internal:172.20.8.18/65181 duration 0:00:00 bytes 602 TCP FINs";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}