import Foundation
let pattern = #"(?P<Timestamp>\b(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)\b[\s+\w+]+[\w+:?]+)\s+(?<SourceIP>[\d+\.?]+)\s+(?P<EventID>%PIX-6-\d+):\s+(?P<EventMessage>Teardown TCP connection\s+\d+) for (?P<OutsideIP>.*?) to (?P<InternalIP>.*?)\s+duration\s+(?P<Duration>.*?)\s+bytes(?P<Bytes>\s+\d+)\s+(?P<TCPstatus>.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Jul 25 23:56:20 210.56.128.109 %PIX-6-302014: Teardown TCP connection 71946380 for Outside:203.117.152.202/80 to Corp-DMZ:proxy2/14266 duration 0:00:00 bytes 557 TCP FINs
Jul 25 23:56:20 210.56.128.109 %PIX-6-302014: Teardown TCP connection 71946381 for Corp-DMZ:proxy2/8080 to Internal:172.20.8.18/65181 duration 0:00:00 bytes 602 TCP FINs
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)