using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:""[^""]*""|[^;])+";
string input = @"_-₪* #,##0.00_-;-₪* #,##0.00_-;"" ; asd""_-₪* ""-""??_-;_-@_-";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}