package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)(?:"[^"]*"|[^;])+`)
var str = `_-₪* #,##0.00_-;-₪* #,##0.00_-;" ; asd"_-₪* "-"??_-;_-@_-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}