re = /(?:"[^"]*"|[^;])+/i
str = '_-₪* #,##0.00_-;-₪* #,##0.00_-;" ; asd"_-₪* "-"??_-;_-@_-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end