#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<othermeta content="V6" name="version"\/>)(?![\s\S]*<othermeta content="V7" name="version"\/>)" & @CRLF & _
""
Local $sString = "I will search for V6" & @CRLF & _
"" & @CRLF & _
"If i find V6, i'll check for V7 AFTER V7" & @CRLF & _
"" & @CRLF & _
"If V7 does not exist i will match V6 and replace it" & @CRLF & _
"If V7 exists AFTER V6, i will NOT match V6" & @CRLF & _
"BUG: If V7 exists BEFORE V6, i will match V6 (i don't know how to create a REGEX that looks ahead and behind)" & @CRLF & _
"" & @CRLF & _
"Test it by changing Vy below to V7 and the match will be gone." & @CRLF & _
"BUG: If you change Vx to V7 it will still match V6. " & @CRLF & _
"" & @CRLF & _
"<othermeta content="Vx" name="version"/>" & @CRLF & _
"<othermeta content="V5" name="version"/>" & @CRLF & _
"<othermeta content="V6" name="version"/>" & @CRLF & _
"<othermeta content="V6.1" name="version"/>" & @CRLF & _
"<othermeta content="V" name="version"/>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")