import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<othermeta content=\"V6\" name=\"version\"\\/>)(?![\\s\\S]*<othermeta content=\"V7\" name=\"version\"\\/>)\n";
final String string = "I will search for V6\n\n"
+ "If i find V6, i'll check for V7 AFTER V7\n\n"
+ "If V7 does not exist i will match V6 and replace it\n"
+ "If V7 exists AFTER V6, i will NOT match V6\n"
+ "BUG: If V7 exists BEFORE V6, i will match V6 (i don't know how to create a REGEX that looks ahead and behind)\n\n"
+ "Test it by changing Vy below to V7 and the match will be gone.\n"
+ "BUG: If you change Vx to V7 it will still match V6. \n\n"
+ "<othermeta content=\"Vx\" name=\"version\"/>\n"
+ "<othermeta content=\"V5\" name=\"version\"/>\n"
+ "<othermeta content=\"V6\" name=\"version\"/>\n"
+ "<othermeta content=\"V6.1\" name=\"version\"/>\n"
+ "<othermeta content=\"V\" name=\"version\"/>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}