using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(""[^""]+""|[0-9]+),(""[^""]+""|[0-9]+),(""[^""]+""|[0-9]+),(""[^""]+""|[0-9]+),(""[^""]+""|[0-9]+),?$";
string input = @"""one"",""two,200"",50,""asd_three"",0
""one"",""two00"",50,""asd,three"",0
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}