import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\"[^\"]+\"|[0-9]+),(\"[^\"]+\"|[0-9]+),(\"[^\"]+\"|[0-9]+),(\"[^\"]+\"|[0-9]+),(\"[^\"]+\"|[0-9]+),?$";
final String string = "\"one\",\"two,200\",50,\"asd_three\",0\n"
+ "\"one\",\"two00\",50,\"asd,three\",0\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}