$re = '/^("[^"]+"|[0-9]+),("[^"]+"|[0-9]+),("[^"]+"|[0-9]+),("[^"]+"|[0-9]+),("[^"]+"|[0-9]+),?$/m';
$str = '"one","two,200",50,"asd_three",0
"one","two00",50,"asd,three",0
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);