$re = '/^\*\*HEADERONE\*\*(?:\r?\n-\s*\[[^][]*].*)*/m';
$str = 'A body paragraph about other things. Lorem ipsom and all that
**HEADERONE**
- [x] Logged In
- [ ] Logged Out
- [x] Spun Around
- [x] Did the hokey pokey
Maybe a link here www.go_ogle.com
Another list that isn\'t important
- [ ] Thing one
- [ ] Thing two
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);