import re
regex = re.compile(r"^\*\*HEADERONE\*\*(?:\r?\n-\s*\[[^][]*].*)*", flags=re.MULTILINE)
test_str = ("A body paragraph about other things. Lorem ipsom and all that\n\n"
"**HEADERONE**\n"
"- [x] Logged In\n"
"- [ ] Logged Out\n"
"- [x] Spun Around\n"
"- [x] Did the hokey pokey\n\n"
"Maybe a link here www.go_ogle.com \n\n"
"Another list that isn't important\n"
"- [ ] Thing one\n"
"- [ ] Thing two\n"
"Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")