# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.\\/(.*\.)RAW$/$1JPG/gm;t' <<< "INPUT:
./Foo/Foo Bar/CL2/RA.W/DSC_09108.RAW
Desired result:
Volumes/Ram/CL2/RAW/DSC_09108.JPG
"