using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"From: .+?<(.+?)>.+?X-Sender: \1\b";
string input = @"From: some text
<notthatmail.com>
X-Sender: notthatmail.com";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}