re = /From: .+?<(.+?)>.+?X-Sender: \1\b/m
str = 'From: some text
<notthatmail.com>
X-Sender: notthatmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end