$re = '/From: .+?<(.+?)>.+?X-Sender: \1\b/ms';
$str = 'From: some text
<notthatmail.com>
X-Sender: notthatmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);