import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((\\w+\\^\\(.*?\\)|([\\w\\^]+))|(\\(?\\(([^\\(\\)]+)\\)\\)?))(((\\/)(?!\\-))|((\\*)(?!\\-))|(\\/\\-)|(\\*\\-))?\\(([^\\(\\)]+)\\))|(\\(([^\\(\\)]+)\\)((((\\/)(?!\\-))|((\\*)(?!\\-))|(\\/\\-)|(\\*\\-))?((\\w+\\^\\(.*?\\)|([\\w\\^]+))|(\\(?\\(([^\\(\\)]+)\\)\\)?))))";
final String string = "(sdf^sdf*(sdf*(23^3s)))*sdf\n"
+ "(232^23)dfdf+dfd(sfsf)\n"
+ "dfd(sfsf^sdf+323)/-13+sfdfsdf\n"
+ "(dfd^23sdf)-(234^dfd)\n"
+ "(dfd^23sdf)-(234^dfd)*(x-3)";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}