const regex = /(((\w+\^\(.*?\)|([\w\^]+))|(\(?\(([^\(\)]+)\)\)?))(((\/)(?!\-))|((\*)(?!\-))|(\/\-)|(\*\-))?\(([^\(\)]+)\))|(\(([^\(\)]+)\)((((\/)(?!\-))|((\*)(?!\-))|(\/\-)|(\*\-))?((\w+\^\(.*?\)|([\w\^]+))|(\(?\(([^\(\)]+)\)\)?))))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((\\w+\\^\\(.*?\\)|([\\w\\^]+))|(\\(?\\(([^\\(\\)]+)\\)\\)?))(((\\\/)(?!\\-))|((\\*)(?!\\-))|(\\\/\\-)|(\\*\\-))?\\(([^\\(\\)]+)\\))|(\\(([^\\(\\)]+)\\)((((\\\/)(?!\\-))|((\\*)(?!\\-))|(\\\/\\-)|(\\*\\-))?((\\w+\\^\\(.*?\\)|([\\w\\^]+))|(\\(?\\(([^\\(\\)]+)\\)\\)?))))', 'g')
const str = `(sdf^sdf*(sdf*(23^3s)))*sdf
(232^23)dfdf+dfd(sfsf)
dfd(sfsf^sdf+323)/-13+sfdfsdf
(dfd^23sdf)-(234^dfd)
(dfd^23sdf)-(234^dfd)*(x-3)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}