re = /(((\w+\^\(.*?\)|([\w\^]+))|(\(?\(([^\(\)]+)\)\)?))(((\/)(?!\-))|((\*)(?!\-))|(\/\-)|(\*\-))?\(([^\(\)]+)\))|(\(([^\(\)]+)\)((((\/)(?!\-))|((\*)(?!\-))|(\/\-)|(\*\-))?((\w+\^\(.*?\)|([\w\^]+))|(\(?\(([^\(\)]+)\)\)?))))/x
str = '(sdf^sdf*(sdf*(23^3s)))*sdf
(232^23)dfdf+dfd(sfsf)
dfd(sfsf^sdf+323)/-13+sfdfsdf
(dfd^23sdf)-(234^dfd)
(dfd^23sdf)-(234^dfd)*(x-3)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end