using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\t|,)([a-z].*?)(:)";
string input = @"Lorem ipsum dolor sit amet,app_open_icon:consectetur adipiscing...
asdf app_open_icon: asdfdsa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}