re = /(?<=\t|,)([a-z].*?)(:)/m
str = 'Lorem ipsum dolor sit amet,app_open_icon:consectetur adipiscing...
asdf app_open_icon: asdfdsa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end