package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w\s]+:[\s\d.,:-]+\.`)
var str = `Выбранное дата и время доставки: 21.05.2020, 12:00 - 14:00. сдача`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}