const regex = /[\w\s]+:[\s\d.,:-]+\./u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\w\\s]+:[\\s\\d.,:-]+\\.', 'u')
const str = `Выбранное дата и время доставки: 21.05.2020, 12:00 - 14:00. сдача`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}