$re = '/[\w\s]+:[\s\d.,:-]+\./u';
$str = 'Выбранное дата и время доставки: 21.05.2020, 12:00 - 14:00. сдача';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);