using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"package:\K\D+";
string input = @"{.package:base73
for.package:base476
:.package:base9
print.package:graphics834";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}