import re
regex = re.compile(r"package:\K\D+", flags=re.MULTILINE)
test_str = ("{.package:base73\n"
"for.package:base476\n"
":.package:base9\n"
"print.package:graphics834")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")