use strict;
my $str = 'Hello,
Please release.
Please find below the retail cash forecast that will be drafted xx/xx/xxxx.
RUN ID No. Amount Curr.
xxxxx - Direct Debit 13 10,706,855.69 USD
xxxxx - Direct Credit 213122 (10,365,481.96) USD
TOTAL 341,373.73 USD
';
my $regex = qr/\bDebit\s*\d*\s+([0-9,.]*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}