import Foundation
let pattern = #"\bDebit\s*\d*\s+([0-9,.]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hello,
Please release.
Please find below the retail cash forecast that will be drafted xx/xx/xxxx.
RUN ID No. Amount Curr.
xxxxx - Direct Debit 13 10,706,855.69 USD
xxxxx - Direct Credit 213122 (10,365,481.96) USD
TOTAL 341,373.73 USD
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)