$re = '/\bwith\b((?:(?!\bwith\b)[^,])*),/m';
$str = 'This is a test with a string with punctuation, and an end. Then test words, and more text. And here whith more text with more punctuation, like that.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);