re = /\bwith\b((?:(?!\bwith\b)[^,])*),/m
str = 'This is a test with a string with punctuation, and an end. Then test words, and more text. And here whith more text with more punctuation, like that.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end