import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![^\\n(]*?def)[^\\n(]*+\\K\\(";
final String string = "def a(self)\n"
+ "def ab(self)\n"
+ "def abc(self)\n"
+ "def abcd(self)\n\n"
+ "a(self)\n"
+ "ab(self)\n"
+ "abc(self)\n"
+ "abcd(self)\n\n"
+ "It should not match lines with:\n\n"
+ " anything def anything(thing)\n\n"
+ "And only match lines as:\n\n"
+ " anything anything(thing)\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}