re = /^(?![^\n(]*?def)[^\n(]*+\K\(/m
str = 'def a(self)
def ab(self)
def abc(self)
def abcd(self)
a(self)
ab(self)
abc(self)
abcd(self)
It should not match lines with:
anything def anything(thing)
And only match lines as:
anything anything(thing)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end