import Foundation
let pattern = #"^(?![^\n(]*?def)[^\n(]*+\K\("#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
def a(self)
def ab(self)
def abc(self)
def abcd(self)
a(self)
ab(self)
abc(self)
abcd(self)
It should not match lines with:
anything def anything(thing)
And only match lines as:
anything anything(thing)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)