const regex = /(?<=https?:\/\/(?:www\.)?)(?!www\.).+?(?=\/)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=https?:\\\/\\\/(?:www\\.)?)(?!www\\.).+?(?=\\\/)', 'g')
const str = `(http://web.archive.org/web/20080620033027/http://www.mrvc.indianrail.gov.in/overview.htm)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);