$re = '/(?<=https?:\/\/(?:www\.)?)(?!www\.).+?(?=\/)/';
$str = '(http://web.archive.org/web/20080620033027/http://www.mrvc.indianrail.gov.in/overview.htm)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;