re = /(?<=https?:\/\/(?:www\.)?)(?!www\.).+?(?=\/)/
str = '(http://web.archive.org/web/20080620033027/http://www.mrvc.indianrail.gov.in/overview.htm)'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result