import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "PAS_BEGIN_0009999(.*?)PAS_END_0009999";
final String string = "PAS_BEGIN_0009999\n"
+ " T71_MANUFACTURER_4=98\n"
+ " T71_COLOR_ID_7=000\n"
+ " T71_OS_7=08\n"
+ "PAS_END_0009999\n\n"
+ "PAS_BEGIN_0009996\n"
+ " T72_VAS_SERVICE_IDENTIFIER_6=\n"
+ " T72_ORDER_NB_7=0003\n"
+ " T72_TECHNOLOGY_7=01\n"
+ "PAS_END_0009996\n\n"
+ "TPV_BEGIN\n"
+ " PAS_20819001=3600000 \n"
+ "TPV_END";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}