import re
regex = re.compile(r"PAS_BEGIN_0009999(.*?)PAS_END_0009999", flags=re.DOTALL)
test_str = ("PAS_BEGIN_0009999\n"
" T71_MANUFACTURER_4=98\n"
" T71_COLOR_ID_7=000\n"
" T71_OS_7=08\n"
"PAS_END_0009999\n\n"
"PAS_BEGIN_0009996\n"
" T72_VAS_SERVICE_IDENTIFIER_6=\n"
" T72_ORDER_NB_7=0003\n"
" T72_TECHNOLOGY_7=01\n"
"PAS_END_0009996\n\n"
"TPV_BEGIN\n"
" PAS_20819001=3600000 \n"
"TPV_END")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")