const regex = /(%([A-Z][0-9]|[0-9][A-Z]|[0-9]+|[A-Z]+))+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(%([A-Z][0-9]|[0-9][A-Z]|[0-9]+|[A-Z]+))+', 'gm')
const str = `/historical-rainfall-trends-south-africa-1921%C3%A2%E2%82%AC%E2%80%9C2015.pdf
/historical-rainfall-trends-south-africa-1921–2015.pdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}