$re = '/(%([A-Z][0-9]|[0-9][A-Z]|[0-9]+|[A-Z]+))+/m';
$str = '/historical-rainfall-trends-south-africa-1921%C3%A2%E2%82%AC%E2%80%9C2015.pdf
/historical-rainfall-trends-south-africa-1921–2015.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);