import re
regex = re.compile(r"(%([A-Z][0-9]|[0-9][A-Z]|[0-9]+|[A-Z]+))+", flags=re.MULTILINE)
test_str = ("/historical-rainfall-trends-south-africa-1921%C3%A2%E2%82%AC%E2%80%9C2015.pdf\n\n"
"/historical-rainfall-trends-south-africa-1921–2015.pdf")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")