#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^(?:[\t ]*(?:\r?\n|\r))+"
Local $sString = "55" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Acqua Woman" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Acqua Woman" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Adriana" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Adriana" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Adriana" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Adriana Rose" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Adriana Rose" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Adriana Rose" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")