re = /^(?:[\t ]*(?:\r?\n|\r))+/m
str = '55
Acqua Woman
Acqua Woman
Adriana
Adriana
Adriana
Adriana Rose
Adriana Rose
Adriana Rose
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end