using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<br \/>\n?(?<replace>.*)<br \/>";
string input = @"<div>
<p>Some content</p>
<br />
<b>Notice</b>: Undefined variable: XXX in <b>YYY</b> on line <b>ZZZ</b><br />
<p>Some other content</p>
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}