$re = '/<br \/>\n?(?<replace>.*)<br \/>/m';
$str = '<div>
<p>Some content</p>
<br />
<b>Notice</b>: Undefined variable: XXX in <b>YYY</b> on line <b>ZZZ</b><br />
<p>Some other content</p>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);