using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!@\{)(?<=\{).*?(?=\})";
string input = @" 1 {eww} r23r23{fetwe}
2 #{d2dded}
3 @{d2dded}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}